What’s Vulnerable › Vulnerabilities
CVE-2024-1176: HT Easy GA4 – Google Analytics WordPress Plugin <= 1.1.5 - Missing Authorization to Unauthenticated GA4 Email Update
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-13 · updated 2026-06-17
- Weakness: CWE-862
Description
The HT Easy GA4 – Google Analytics WordPress Plugin plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the login() function in all versions up to, and including, 1.1.5. This makes it possible for unauthenticated attackers to update the email associated through the plugin with GA4.
Affected products
- htplugins HT Easy GA4 – Google Analytics WordPress Plugin: before 1.2.0 — fixed in 1.2.0
How to fix
Upgrade to a fixed version: htplugins HT Easy GA4 – Google Analytics WordPress Plugin 1.2.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/ht-easy-google-analytics/trunk/includes/class.ht-easy-ga4.php#L99
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3055939%40ht-easy-google-analytics&new=3055939%40ht-easy-google-analytics&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/10e1b3ac-f002-4108-9682-5fe300f07adb?source=cve
- https://plugins.trac.wordpress.org/browser/ht-easy-google-analytics/trunk/includes/class.ht-easy-ga4.php#L99
- https://www.wordfence.com/threat-intel/vulnerabilities/id/10e1b3ac-f002-4108-9682-5fe300f07adb?source=cve
Get alerted when CVE-2024-1176 or the next vulnerability affects your stack