What’s Vulnerable › Vulnerabilities
CVE-2024-11780: Site Search 360 <= 2.1.6 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-01 · updated 2026-06-17
- Weakness: CWE-79
Description
The Site Search 360 plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'ss360-resultblock' shortcode in all versions up to, and including, 2.1.6 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- dsky Site Search 360: before 2.1.7 — fixed in 2.1.7
How to fix
Upgrade to a fixed version: dsky Site Search 360 2.1.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3232517%40site-search-360&new=3232517%40site-search-360&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/4af66bb2-febe-4022-9526-39b1ecd8b01d?source=cve
Get alerted when CVE-2024-11780 or the next vulnerability affects your stack