What’s Vulnerable › Vulnerabilities
CVE-2024-1180: TP-Link Omada ER605 Access Control Command Injection Remote Code Execution Vulnerability
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-04-03 · updated 2026-06-17
- Weakness: CWE-78
Description
TP-Link Omada ER605 Access Control Command Injection Remote Code Execution Vulnerability. This vulnerability allows network-adjacent attackers to execute arbitrary code on affected installations of TP-Link Omada ER605. Authentication is required to exploit this vulnerability. The specific issue exists within the handling of the name field in the access control user interface. The issue results from the lack of proper validation of a user-supplied string before using it to execute a system call. An attacker can leverage this vulnerability to execute code in the context of root. Was ZDI-CAN-22227.
Affected products
- TP-Link Omada ER605: before 2.2.3 — fixed in 2.2.3
How to fix
Upgrade to a fixed version: TP-Link Omada ER605 2.2.3. Check the vendor advisory for mitigations.
References
- https://www.zerodayinitiative.com/advisories/ZDI-24-086/
- https://www.zerodayinitiative.com/advisories/ZDI-24-086/
Get alerted when CVE-2024-1180 or the next vulnerability affects your stack