What’s Vulnerable › Vulnerabilities
CVE-2024-11824: Stored XSS in langgenius/dify
- Severity: high (CVSS 7.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-20 · updated 2026-06-17
- Weakness: CWE-79
Description
A stored cross-site scripting (XSS) vulnerability exists in langgenius/dify version latest, specifically in the chat log functionality. The vulnerability arises because certain HTML tags like <input> and <form> are not disallowed, allowing an attacker to inject malicious HTML into the log via prompts. When an admin views the log containing the malicious HTML, the attacker could steal the admin's credentials or sensitive information. This issue is fixed in version 0.12.1.
Affected products
- langgenius dify: before 0.12.1 — fixed in 0.12.1
How to fix
Upgrade to a fixed version: langgenius dify 0.12.1. Check the vendor advisory for mitigations.
References
- https://github.com/langgenius/dify/commit/55edd5047e6fcbc9bb56a4ea055fcce090f3eb5d
- https://huntr.com/bounties/72387deb-6e64-48ed-a8c3-b50d22a0970f
Get alerted when CVE-2024-11824 or the next vulnerability affects your stack