What’s Vulnerable › Vulnerabilities
CVE-2024-11826: Quill Forms | The Best Typeform Alternative | Create Conversational Multi Step Form, Survey, Quiz, Cost Estimation or Donation Form on WordPress <= 3.10.0 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-07 · updated 2026-06-17
- Weakness: CWE-79
Description
The Quill Forms | The Best Typeform Alternative | Create Conversational Multi Step Form, Survey, Quiz, Cost Estimation or Donation Form on WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'quillforms-popup' shortcode in all versions up to, and including, 3.10.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- mdmag Quill Forms | Conversational Multi Step Forms, Surveys & quizzes: before 4.0.0 — fixed in 4.0.0
How to fix
Upgrade to a fixed version: mdmag Quill Forms | Conversational Multi Step Forms, Surveys & quizzes 4.0.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3214019/quillforms/trunk/includes/class-shortcode.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/d59a4d69-cf51-44c1-90bf-19be04774c27?source=cve
Get alerted when CVE-2024-11826 or the next vulnerability affects your stack