What’s Vulnerable › Vulnerabilities
CVE-2024-11844: IdeaPush <= 8.71 - Missing Authorization to Board Term Deletion
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-03 · updated 2026-06-17
- Weakness: CWE-862
Description
The IdeaPush plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the idea_push_taxonomy_save_routine function in all versions up to, and including, 8.71. This makes it possible for authenticated attackers, with Subscriber-level access and above, to delete terms for the "boards" taxonomy.
Affected products
- Martin Gibson IdeaPush: before 8.72 — fixed in 8.72
How to fix
Upgrade to a fixed version: Martin Gibson IdeaPush 8.72. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/ideapush/trunk/ideapush.php#L766
- https://plugins.trac.wordpress.org/changeset/3198488/ideapush/trunk/ideapush.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/34603c3f-834f-4a2a-9b9f-5213155d4317?source=cve
Get alerted when CVE-2024-11844 or the next vulnerability affects your stack