What’s Vulnerable › Vulnerabilities
CVE-2024-11868: LearnPress – WordPress LMS Plugin <= 4.2.7.3 - Course Material Sensitive Information Exposure via REST API
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-12-10 · updated 2026-06-17
- Weakness: CWE-284
Description
The LearnPress – WordPress LMS Plugin plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 4.2.7.3 via class-lp-rest-material-controller.php. This makes it possible for unauthenticated attackers to extract potentially sensitive paid course material.
Affected products
- thimpress LearnPress – WordPress LMS Plugin for Create and Sell Online Courses: before 4.2.7.4 — fixed in 4.2.7.4
How to fix
Upgrade to a fixed version: thimpress LearnPress – WordPress LMS Plugin for Create and Sell Online Courses 4.2.7.4. Check the vendor advisory for mitigations.
References
- https://abrahack.com/posts/learnpress-sensitive-information-exposure/
- https://plugins.trac.wordpress.org/changeset/3200780/learnpress
- https://www.wordfence.com/threat-intel/vulnerabilities/id/7bd43980-9193-4a63-adba-720dd1b11699?source=cve
Get alerted when CVE-2024-11868 or the next vulnerability affects your stack