What’s Vulnerable › Vulnerabilities
CVE-2024-11888: IDer Login for WordPress <= 2.1 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-14 · updated 2026-06-17
- Weakness: CWE-79
Description
The IDer Login for WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'ider_login_button' shortcode in all versions up to, and including, 2.1 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This affects version 2.1, but was also patched in version 2.1 - a new version was not released with the patch.
Affected products
- IDer Login for WordPress: through 2.1
References
- https://plugins.trac.wordpress.org/browser/ider-login/trunk/includes/IDER_Shortcodes.php#L49
- https://plugins.trac.wordpress.org/changeset/3279435/ider-login/trunk/includes/IDER_Shortcodes.php
- https://wordpress.org/plugins/ider-login
- https://www.wordfence.com/threat-intel/vulnerabilities/id/de602cf8-cc02-4459-aa23-5d8236048bca?source=cve
Get alerted when CVE-2024-11888 or the next vulnerability affects your stack