What’s Vulnerable › Vulnerabilities
CVE-2024-1189: AMPPS Encryption Passphrase denial of service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-02-02 · updated 2026-06-17
- Weakness: CWE-404
Description
A vulnerability has been found in AMPPS 2.7 and classified as problematic. Affected by this vulnerability is an unknown functionality of the component Encryption Passphrase Handler. The manipulation leads to denial of service. The attack can be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 4.0 is able to address this issue. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-252679. NOTE: The vendor explains that AMPPS 4.0 is a complete overhaul and the code was re-written.
Affected products
- AMPPS: before 4.0 — fixed in 4.0
How to fix
Upgrade to a fixed version: AMPPS 4.0. Check the vendor advisory for mitigations.
References
- https://fitoxs.com/vuldb/15-exploit-perl.txt
- https://vuldb.com/?ctiid.252679
- https://vuldb.com/?id.252679
- https://fitoxs.com/vuldb/15-exploit-perl.txt
- https://vuldb.com/?ctiid.252679
- https://vuldb.com/?id.252679
Get alerted when CVE-2024-1189 or the next vulnerability affects your stack