What’s Vulnerable › Vulnerabilities
CVE-2024-11895: Online Payments – Get Paid with PayPal, Square & Stripe <= 3.20.0 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-18 · updated 2026-06-17
- Weakness: CWE-79
Description
The Online Payments – Get Paid with PayPal, Square & Stripe plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's shortcodes in all versions up to, and including, 3.20.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- vcita Online Payments – Get Paid with PayPal, Square & Stripe: before 3.30.0 — fixed in 3.30.0
How to fix
Upgrade to a fixed version: vcita Online Payments – Get Paid with PayPal, Square & Stripe 3.30.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/paypal-payment-button-by-vcita/tags/3.10.0/core/shortcodes.php#L129
- https://plugins.trac.wordpress.org/browser/paypal-payment-button-by-vcita/tags/3.10.0/core/shortcodes.php#L22
- https://plugins.trac.wordpress.org/browser/paypal-payment-button-by-vcita/tags/3.10.0/core/shortcodes.php#L50
- https://plugins.trac.wordpress.org/browser/paypal-payment-button-by-vcita/tags/3.10.0/core/shortcodes.php#L91
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3241650%40paypal-payment-button-by-vcita&new=3241650%40paypal-payment-button-by-vcita&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/aab33299-f02d-44a1-9522-5309eed6fd38?source=cve
Get alerted when CVE-2024-11895 or the next vulnerability affects your stack