What’s Vulnerable › Vulnerabilities
CVE-2024-11930: Taskbuilder – WordPress Project & Task Management plugin <= 3.0.6 - Authenticated (Contributor+) Stored Cross-Site Scripting via wppm_tasks Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-04 · updated 2026-06-17
- Weakness: CWE-79
Description
The Taskbuilder – WordPress Project & Task Management plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's wppm_tasks shortcode in all versions up to, and including, 3.0.6 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- Taskbuilder: before 3.0.7 — fixed in 3.0.7
How to fix
Upgrade to a fixed version: Taskbuilder 3.0.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/taskbuilder/trunk/includes/frontend/wppm_tasks_shortcode.php#L123
- https://plugins.trac.wordpress.org/changeset/3210469/
- https://wordpress.org/plugins/taskbuilder/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/fdc39d59-7c9d-4d5d-9fb5-b67d2324adaa?source=cve
Get alerted when CVE-2024-11930 or the next vulnerability affects your stack