What’s Vulnerable › Vulnerabilities

CVE-2024-11931: Insufficient Granularity of Access Control in GitLab

Description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 17.0 prior to 17.6.4, from 17.7 prior to 17.7.3, and from 17.8 prior to 17.8.1. Under certain conditions, it may have been possible for users with developer role to exfiltrate protected CI variables via CI lint.

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.6.4, 17.7.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-11931 or the next vulnerability affects your stack