What’s Vulnerable › Vulnerabilities
CVE-2024-11947: GFI Archiver Core Service Deserialization of Untrusted Data Remote Code Execution Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-12 · updated 2026-06-17
- Weakness: CWE-502
Description
GFI Archiver Core Service Deserialization of Untrusted Data Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of GFI Archiver. Authentication is required to exploit this vulnerability. The specific flaw exists within the Core Service, which listens on TCP port 8017 by default. The issue results from the lack of proper validation of user-supplied data, which can result in deserialization of untrusted data. An attacker can leverage this vulnerability to execute code in the context of SYSTEM. Was ZDI-CAN-24029.
Affected products
- GFI Archiver: before 15.7 — fixed in 15.7
How to fix
Upgrade to a fixed version: GFI Archiver 15.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-11947 or the next vulnerability affects your stack