What’s Vulnerable › Vulnerabilities
CVE-2024-11958: SQL Injection in run-llama/llama_index
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-20 · updated 2026-06-17
- Weakness: CWE-89
Description
A SQL injection vulnerability exists in the `duckdb_retriever` component of the run-llama/llama_index repository, specifically in the latest version. The vulnerability arises from the construction of SQL queries without using prepared statements, allowing an attacker to inject arbitrary SQL code. This can lead to remote code execution (RCE) by installing the shellfs extension and executing malicious commands.
Affected products
- run-llama/llama_index: before 0.4.0 — fixed in 0.4.0
How to fix
Upgrade to a fixed version: run-llama/llama_index 0.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/run-llama/llama_index/commit/35bd221e948e40458052d30c6ef2779bc965b6d0
- https://huntr.com/bounties/8ddf66e1-f74c-4d53-992b-76bc45cacac1
Get alerted when CVE-2024-11958 or the next vulnerability affects your stack