What’s Vulnerable › Vulnerabilities
CVE-2024-11972: Hunk Companion < 1.9.0 - Unauthenticated Plugin Installation
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 59.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-12-31 · updated 2026-06-17
Description
The Hunk Companion WordPress plugin before 1.9.0 does not correctly authorize some REST API endpoints, allowing unauthenticated requests to install and activate arbitrary Hunk Companion WordPress plugin before 1.9.0 from the WordPress.org repo, including vulnerable Hunk Companion WordPress plugin before 1.9.0 that have been closed.
Affected products
- Hunk Companion: before 1.9.0 — fixed in 1.9.0
How to fix
Upgrade to a fixed version: Hunk Companion 1.9.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-11972 or the next vulnerability affects your stack