What’s Vulnerable › Vulnerabilities
CVE-2024-11994: APM Server Insertion of Sensitive Information into Log File
- Severity: medium (CVSS 5.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-01 · updated 2026-06-17
- Weakness: CWE-200
Description
APM server logs could contain parts of the document body from a partially failed bulk index request. Depending on the nature of the document, this could disclose sensitive information in APM Server error logs.
Affected products
- Elastic APM Server: from 8.0.0 before 8.16.1 — fixed in 8.16.1
How to fix
Upgrade to a fixed version: Elastic APM Server 8.16.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-11994 or the next vulnerability affects your stack