What’s Vulnerable › Vulnerabilities
CVE-2024-12005: WP-BibTeX <= 3.0.1 - Cross-Site Request Forgery to Stored and Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-21 · updated 2026-06-17
- Weakness: CWE-352
Description
The WP-BibTeX plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 3.0.1. This is due to missing or incorrect nonce validation on the wp_bibtex_option_page() function. This makes it possible for unauthenticated attackers to inject malicious web scripts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- zjhzxhz WP-BibTeX: before 3.0.2 — fixed in 3.0.2
How to fix
Upgrade to a fixed version: zjhzxhz WP-BibTeX 3.0.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wp-bibtex/trunk/wp-bibtex-options.php#L55
- https://plugins.trac.wordpress.org/changeset/3225023
- https://wordpress.org/plugins/wp-bibtex/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/077538e2-ef9a-490f-9188-31f9cb82aaf7?source=cve
Get alerted when CVE-2024-12005 or the next vulnerability affects your stack