What’s Vulnerable › Vulnerabilities
CVE-2024-12021: Stored Cross-Site Scripting
- Severity: high (CVSS 8.5 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-31 · updated 2026-06-17
- Weakness: CWE-79
Description
Coverity versions prior to 2024.9.0 are vulnerable to stored cross-site scripting (XSS) in various administrative interfaces. The impact of exploitation may result in the compromise of local accounts managed by the Coverity platform as well as other standard impacts resulting from cross-site scripting.
Affected products
- Black Duck Coverity: before 2024.9.0 — fixed in 2024.9.0
How to fix
Upgrade to a fixed version: Black Duck Coverity 2024.9.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-12021 or the next vulnerability affects your stack