What’s Vulnerable › Vulnerabilities
CVE-2024-12033: Jupiter X Core <= 4.8.5 - Missing Authorization to Authenticated Library Sync
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-07 · updated 2026-06-17
- Weakness: CWE-862
Description
The Jupiter X Core plugin for WordPress is vulnerable to unauthorized access due to a missing capability check on the sync_libraries() function in all versions up to, and including, 4.8.5. This makes it possible for authenticated attackers, with Subscriber-level access and above, to sync libraries
Affected products
- artbees Jupiter X Core: before 4.8.6 — fixed in 4.8.6
How to fix
Upgrade to a fixed version: artbees Jupiter X Core 4.8.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3214798/jupiterx-core/trunk/includes/extensions/raven/includes/plugin.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/7e452aa0-bfb9-4805-b2ed-53464a4b5308?source=cve
Get alerted when CVE-2024-12033 or the next vulnerability affects your stack