What’s Vulnerable › Vulnerabilities
CVE-2024-12038: Frontend Content Forms for User Submissions (UGC) <= 2.8.15 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'buddyforms_nav' Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-22 · updated 2026-06-17
- Weakness: CWE-79
Description
The Post Form – Registration Form – Profile Form for User Profiles – Frontend Content Forms for User Submissions (UGC) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'buddyforms_nav' shortcode in all versions up to, and including, 2.8.15 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- Themekraft BuddyForms: before 2.8.16 — fixed in 2.8.16
How to fix
Upgrade to a fixed version: Themekraft BuddyForms 2.8.16. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3244167/buddyforms/trunk/includes/shortcodes.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ff0568e2-3a1e-4ed6-835a-37e3d07d7b63?source=cve
Get alerted when CVE-2024-12038 or the next vulnerability affects your stack