What’s Vulnerable › Vulnerabilities
CVE-2024-12047: WP Compress – Instant Performance & Speed Optimization <= 6.30.03 - Reflected Cross-Site Scripting via custom_server Parameter
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-04 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Compress – Instant Performance & Speed Optimization plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the ‘custom_server’ parameter in all versions up to, and including, 6.30.03 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Affected products
- aresit WP Compress – Instant Performance & Speed Optimization: before 6.30.04 — fixed in 6.30.04
How to fix
Upgrade to a fixed version: aresit WP Compress – Instant Performance & Speed Optimization 6.30.04. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wp-compress-image-optimizer/tags/6.30.00/addons/cdn/cdn-rewrite.php#L459
- https://plugins.trac.wordpress.org/changeset/3213738/
- https://wordpress.org/plugins/wp-compress-image-optimizer/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/09c04863-a454-4f05-9403-aff39dbccd43?source=cve
Get alerted when CVE-2024-12047 or the next vulnerability affects your stack