What’s Vulnerable › Vulnerabilities
CVE-2024-12059: ElementInvader Addons for Elementor <= 1.3.1 - Missing Authorization to Arbitrary Options Read
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-12 · updated 2026-06-17
- Weakness: CWE-639
Description
The ElementInvader Addons for Elementor plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.3.1 via the eli_option_value shortcode. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract arbitrary options from the wp_options table.
Affected products
- Element Invader ElementInvader Addons for Elementor: before 1.3.2 — fixed in 1.3.2
How to fix
Upgrade to a fixed version: Element Invader ElementInvader Addons for Elementor 1.3.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3203139%40elementinvader-addons-for-elementor&new=3203139%40elementinvader-addons-for-elementor&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/cf7ec469-70b7-4ec2-83df-c788c76730b4?source=cve
Get alerted when CVE-2024-12059 or the next vulnerability affects your stack