What’s Vulnerable › Vulnerabilities
CVE-2024-12061: Events Addon for Elementor <= 2.2.3 - Authenticated (Contributor+) Post Disclosure
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-18 · updated 2026-06-17
- Weakness: CWE-639
Description
The Events Addon for Elementor plugin for WordPress is vulnerable to Information Exposure in all versions up to, and including, 2.2.3 via the naevents_elementor_template shortcode due to insufficient restrictions on which posts can be included. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract data from private or draft posts created by Elementor that they should not have access to.
Affected products
- nicheaddons Events Addon for Elementor: before 2.2.4 — fixed in 2.2.4
How to fix
Upgrade to a fixed version: nicheaddons Events Addon for Elementor 2.2.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3208546%40events-addon-for-elementor&new=3208546%40events-addon-for-elementor&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f59d9d8a-467a-4920-963a-da45f1f4462f?source=cve
Get alerted when CVE-2024-12061 or the next vulnerability affects your stack