What’s Vulnerable › Vulnerabilities
CVE-2024-12086: Rsync: rsync server leaks arbitrary client files
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-01-14 · updated 2026-08-21
- Weakness: CWE-390
Description
A flaw was found in rsync. It could allow a server to enumerate the contents of an arbitrary file from the client's machine. This issue occurs when files are being copied from a client to a server. During this process, the rsync server will send checksums of local data to the client to compare with in order to determine what data needs to be sent to the server. By sending specially constructed checksum values for arbitrary files, an attacker may be able to reconstruct the data of those files byte-by-byte based on the responses from the client.
Affected products
- Almalinux: 8.0, 9.0, 10.0
- Archlinux Arch Linux: all versions
- gentoo Linux: all versions
- Nixos: before 24.11 — fixed in 24.11
- Red Hat Enterprise Linux: 6.0, 7.0, 8.0, 9.0, 10.0
- Red Hat OpenShift Container Platform 4.18: 4.0
- RsyncProject rsync: through 3.3.0
- Suse Linux: all versions
- Tritondatacenter Smartos: before 20250123 — fixed in 20250123
How to fix
Upgrade to a fixed version: Nixos 24.11; Tritondatacenter Smartos 20250123. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHBA-2025:6470
- https://access.redhat.com/errata/RHSA-2026:19368
- https://access.redhat.com/errata/RHSA-2026:20603
- https://access.redhat.com/errata/RHSA-2026:29197
- https://access.redhat.com/security/cve/CVE-2024-12086
- https://bugzilla.redhat.com/show_bug.cgi?id=2330577
- https://kb.cert.org/vuls/id/952657
- https://lists.debian.org/debian-lts-announce/2025/01/msg00008.html
- https://security.netapp.com/advisory/ntap-20250131-0002/
- https://www.kb.cert.org/vuls/id/952657
- https://github.com/google/security-research/security/advisories/GHSA-p5pg-x43v-mvqj
Get alerted when CVE-2024-12086 or the next vulnerability affects your stack