What’s Vulnerable › Vulnerabilities
CVE-2024-12087: Rsync: path traversal vulnerability in rsync
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-01-14 · updated 2026-10-21
- Weakness: CWE-22
Description
A path traversal vulnerability exists in rsync. It stems from behavior enabled by the `--inc-recursive` option, a default-enabled option for many client options and can be enabled by the server even if not explicitly enabled by the client. When using the `--inc-recursive` option, a lack of proper symlink verification coupled with deduplication checks occurring on a per-file-list basis could allow a server to write files outside of the client's intended destination directory. A malicious server could write malicious files to arbitrary locations named after valid directories/paths on the client.
Affected products
- Almalinux: 8.0, 9.0, 10.0
- Archlinux Arch Linux: all versions
- gentoo Linux: all versions
- Nixos: before 24.11 — fixed in 24.11
- Red Hat Enterprise Linux: 8.0, 9.0
- RedHat Enterprise Linux Eus: 9.6
- RedHat Enterprise Linux For Arm 64: 8.0_aarch64, 9.0_aarch64
- RedHat Enterprise Linux For Arm 64 Eus: 9.6_aarch64
- RedHat Enterprise Linux For Ibm Z Systems: 8.0_s390x, 9.0_s390x
- RedHat Enterprise Linux For Ibm Z Systems Eus: 9.6_s390x
- RedHat Enterprise Linux For Power Little Endian: 8.0_ppc64le, 9.0_ppc64le
- RedHat Enterprise Linux For Power Little Endian Eus: 9.6_ppc64le
- RedHat Enterprise Linux Server Aus: 9.6
- RedHat Enterprise Linux Server For Power Little Endian Update Services For Sap Solutions: 9.6_ppc64le
- RedHat Enterprise Linux Update Services For Sap Solutions: 9.6
- RsyncProject rsync: through 3.3.0
- Suse Linux: all versions
- Tritondatacenter Smartos: before 20250123 — fixed in 20250123
How to fix
Upgrade to a fixed version: Nixos 24.11; Tritondatacenter Smartos 20250123. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHBA-2025:6470
- https://access.redhat.com/errata/RHSA-2025:23154
- https://access.redhat.com/errata/RHSA-2025:23235
- https://access.redhat.com/errata/RHSA-2025:23407
- https://access.redhat.com/errata/RHSA-2025:23415
- https://access.redhat.com/errata/RHSA-2025:23416
- https://access.redhat.com/errata/RHSA-2025:23842
- https://access.redhat.com/errata/RHSA-2025:23853
- https://access.redhat.com/errata/RHSA-2025:23854
- https://access.redhat.com/errata/RHSA-2025:23858
- https://access.redhat.com/errata/RHSA-2025:2600
- https://access.redhat.com/errata/RHSA-2025:7050
Get alerted when CVE-2024-12087 or the next vulnerability affects your stack