What’s Vulnerable › Vulnerabilities
CVE-2024-1209: LearnDash LMS <= 4.10.1 - Sensitive Information Exposure via assignments
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-02-05 · updated 2026-06-17
- Weakness: CWE-200
Description
The LearnDash LMS plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 4.10.1 via direct file access due to insufficient protection of uploaded assignments. This makes it possible for unauthenticated attackers to obtain those uploads.
Affected products
- StellarWP LearnDash LMS: before 4.10.3 — fixed in 4.10.3
How to fix
Upgrade to a fixed version: StellarWP LearnDash LMS 4.10.3. Check the vendor advisory for mitigations.
References
- https://github.com/karlemilnikka/CVE-2024-1209
- https://www.learndash.com/release-notes/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/7191955e-0db1-4ad1-878b-74f90ca59c91?source=cve
- https://github.com/karlemilnikka/CVE-2024-1209
- https://www.learndash.com/release-notes/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/7191955e-0db1-4ad1-878b-74f90ca59c91?source=cve
Get alerted when CVE-2024-1209 or the next vulnerability affects your stack