What’s Vulnerable › Vulnerabilities
CVE-2024-12093: Improper Validation of Consistency within Input in GitLab
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-22 · updated 2026-06-17
- Weakness: CWE-1288
Description
An issue has been discovered in GitLab CE/EE affecting all versions from 11.1 before 17.10.7, 17.11 before 17.11.3, and 18.0 before 18.0.1. Improper XPath validation allows modified SAML response to bypass 2FA requirement under specialized conditions.
Affected products
- GitLab: from 11.1.0 before 17.10.7; from 17.11.0 before 17.11.3; 18.0.0 — fixed in 17.10.7, 17.11.3
How to fix
Upgrade to a fixed version: GitLab 17.10.7, 17.11.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-12093 or the next vulnerability affects your stack