What’s Vulnerable › Vulnerabilities
CVE-2024-12109: Product Labels For Woocommerce < 1.5.9 - Admin+ SQLi
- Severity: medium (CVSS 4.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-25 · updated 2026-06-17
- Weakness: CWE-89
Description
The Product Labels For Woocommerce (Sale Badges) WordPress plugin before 1.5.9 does not sanitize and escape a parameter before using it in a SQL statement, allowing admins to perform SQL injection attacks
Affected products
- Product Labels For Woocommerce (Sale Badges): before 1.5.9 — fixed in 1.5.9
How to fix
Upgrade to a fixed version: Product Labels For Woocommerce (Sale Badges) 1.5.9. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/2eca2f88-c843-4794-8cd9-46f17c92753a/
- https://wpscan.com/vulnerability/2eca2f88-c843-4794-8cd9-46f17c92753a/
Get alerted when CVE-2024-12109 or the next vulnerability affects your stack