What’s Vulnerable › Vulnerabilities

CVE-2024-1211: Cross-Site Request Forgery (CSRF) in GitLab

Description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 10.6 prior to 16.9.7, starting from 16.10 prior to 16.10.5, and starting from 16.11 prior to 16.11.2 in which cross-site request forgery may have been possible on GitLab instances configured to use JWT as an OmniAuth provider.

Affected products

How to fix

Upgrade to a fixed version: GitLab 16.10.5, 16.11.2, 16.9.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-1211 or the next vulnerability affects your stack