What’s Vulnerable › Vulnerabilities
CVE-2024-12115: Poll Maker <= 5.5.4 - Cross-Site Request Forgery to Poll Duplication
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-07 · updated 2026-06-17
- Weakness: CWE-352
Description
The Poll Maker – Versus Polls, Anonymous Polls, Image Polls plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 5.5.4. This is due to missing or incorrect nonce validation on the duplicate_poll() function. This makes it possible for unauthenticated attackers to duplicate polls via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- Ays Pro Poll Maker: before 5.5.5 — fixed in 5.5.5
How to fix
Upgrade to a fixed version: Ays Pro Poll Maker 5.5.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3202972/poll-maker/tags/5.5.5/includes/lists/class-poll-maker-polls-list-table.php?old=3202972&old_path=poll-maker%2Ftags%2F5.5.4%2Fincludes%2Flists%2Fclass-poll-maker-polls-list-table.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e76447ec-2815-4758-ae2c-67a938a739d9?source=cve
Get alerted when CVE-2024-12115 or the next vulnerability affects your stack