What’s Vulnerable › Vulnerabilities
CVE-2024-12120: Royal Elementor Addons and Templates <= 1.7.1017 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-07 · updated 2026-06-17
- Weakness: CWE-79
Description
The Royal Elementor Addons and Templates plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Countdown widget display_message_text parameter in all versions up to, and including, 1.7.1017 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- wproyal Royal Addons for Elementor – Addons and Templates Kit for Elementor: before 1.7.1018 — fixed in 1.7.1018
How to fix
Upgrade to a fixed version: wproyal Royal Addons for Elementor – Addons and Templates Kit for Elementor 1.7.1018. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3236381/royal-elementor-addons/tags/1.7.1008/modules/countdown/widgets/wpr-countdown.php?old=3220755&old_path=royal-elementor-addons%2Ftags%2F1.7.1007%2Fmodules%2Fcountdown%2Fwidgets%2Fwpr-countdown.php
- https://plugins.trac.wordpress.org/changeset/3285549/royal-elementor-addons/tags/1.7.1018/assets/js/frontend.js?old=3277554&old_path=royal-elementor-addons%2Ftags%2F1.7.1017%2Fassets%2Fjs%2Ffrontend.js
- https://www.wordfence.com/threat-intel/vulnerabilities/id/5ee7b4d8-c397-41f6-981f-9a010e4ab2f1?source=cve
Get alerted when CVE-2024-12120 or the next vulnerability affects your stack