What’s Vulnerable › Vulnerabilities
CVE-2024-12148
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-04 · updated 2026-06-17
- Weakness: CWE-863
Description
Incorrect authorization in permission validation component in Devolutions Server 2024.3.6.0 and earlier allows an authenticated user to access some reporting endpoints.
Affected products
- Devolutions Server: before 2024.3.7.0 — fixed in 2024.3.7.0
How to fix
Upgrade to a fixed version: Devolutions Server 2024.3.7.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-12148 or the next vulnerability affects your stack