What’s Vulnerable › Vulnerabilities
CVE-2024-12163: GoodLayers Core < 2.1.3 - Subscriber+ Stored XSS via SVG Upload
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-01-30 · updated 2026-06-17
- Weakness: CWE-79
Description
The goodlayers-core WordPress plugin before 2.1.3 allows users with a subscriber role and above to upload SVGs containing malicious payloads.
Affected products
- goodlayers-core: before 2.1.3 — fixed in 2.1.3
How to fix
Upgrade to a fixed version: goodlayers-core 2.1.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/ea704054-fb66-4014-89bd-1c61074f64e5/
- https://wpscan.com/vulnerability/ea704054-fb66-4014-89bd-1c61074f64e5/
Get alerted when CVE-2024-12163 or the next vulnerability affects your stack