What’s Vulnerable › Vulnerabilities
CVE-2024-12164: WPSyncSheets Lite For WPForms – WPForms Google Spreadsheet Addon <= 1.6 - Missing Authorization to Authenticated (Subscriber+) Settings Reset
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-12 · updated 2026-06-17
- Weakness: CWE-862
Description
The WPSyncSheets Lite For WPForms – WPForms Google Spreadsheet Addon plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the wpsslwp_reset_settings() function in all versions up to, and including, 1.6. This makes it possible for authenticated attackers, with Subscriber-level access and above, to reset the plugin's settings.
Affected products
- creativewerkdesigns WPSyncSheets For WPForms – Google Sheets Connector for WPForms & Real‑Time Data Export: before 1.6.1 — fixed in 1.6.1
How to fix
Upgrade to a fixed version: creativewerkdesigns WPSyncSheets For WPForms – Google Sheets Connector for WPForms & Real‑Time Data Export 1.6.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wpsyncsheets-wpforms/tags/1.5/includes/class-wpsslwp-service.php#L779
- https://plugins.trac.wordpress.org/browser/wpsyncsheets-wpforms/tags/1.5/includes/class-wpsslwp-service.php#L92
- https://plugins.trac.wordpress.org/changeset/3234445/wpsyncsheets-wpforms/tags/1.6.1/includes/class-wpsslwp-service.php?old=3232281&old_path=wpsyncsheets-wpforms%2Ftags%2F1.6%2Fincludes%2Fclass-wpsslwp-service.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/83bd48fb-f5f9-4d3d-8fc4-a06adfa5a225?source=cve
Get alerted when CVE-2024-12164 or the next vulnerability affects your stack