What’s Vulnerable › Vulnerabilities
CVE-2024-12173: Master Slider < 3.10.5 - Editor+ Stored XSS
- Severity: low (CVSS 3.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-02-19 · updated 2026-06-17
- Weakness: CWE-79
Description
The Master Slider WordPress plugin before 3.10.5 does not sanitise and escape some of its settings, which could allow high privilege users such as Editor and above to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- averta Master Slider – Responsive Touch Slider: before 3.10.5 — fixed in 3.10.5
How to fix
Upgrade to a fixed version: averta Master Slider – Responsive Touch Slider 3.10.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-12173 or the next vulnerability affects your stack