What’s Vulnerable › Vulnerabilities
CVE-2024-1219: Easy Social Feed < 6.5.6 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-04-17 · updated 2026-06-17
- Weakness: CWE-79
Description
The Easy Social Feed WordPress plugin before 6.5.6 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admin
Affected products
- sjaved Easy Social Feed – Social Photos Gallery and Post Feed for WordPress: before 6.5.6 — fixed in 6.5.6
How to fix
Upgrade to a fixed version: sjaved Easy Social Feed – Social Photos Gallery and Post Feed for WordPress 6.5.6. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/ce4ac9c4-d293-4464-b6a0-82ddf8d4860b/
- https://wpscan.com/vulnerability/ce4ac9c4-d293-4464-b6a0-82ddf8d4860b/
Get alerted when CVE-2024-1219 or the next vulnerability affects your stack