What’s Vulnerable › Vulnerabilities
CVE-2024-1221: Improper access controls on APIs on Linux and macOS in PaperCut NG/MF
- Severity: low (CVSS 3.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-14 · updated 2026-06-17
- Weakness: CWE-76
Description
This vulnerability potentially allows files on a PaperCut NG/MF server to be exposed using a specifically formed payload against the impacted API endpoint. The attacker must carry out some reconnaissance to gain knowledge of a system token. This CVE only affects Linux and macOS PaperCut NG/MF servers.
Affected products
- PaperCut MF: before 20.1.10; from 21.0.0 before 21.2.14; from 22.0.0 before 22.1.5; from 23.0.1 before 23.0.7 — fixed in 20.1.10, 21.2.14, 22.1.5, 23.0.7
- PaperCut NG: before 20.1.10; from 21.0.0 before 21.2.14; from 22.0.0 before 22.1.5; from 23.0.1 before 23.0.7 — fixed in 20.1.10, 21.2.14, 22.1.5, 23.0.7
How to fix
Upgrade to a fixed version: PaperCut MF 20.1.10, 21.2.14, 22.1.5, 23.0.7; PaperCut NG 20.1.10, 21.2.14, 22.1.5, 23.0.7. Check the vendor advisory for mitigations.
References
- https://www.papercut.com/kb/Main/Security-Bulletin-March-2024
- https://www.papercut.com/kb/Main/Security-Bulletin-March-2024
Get alerted when CVE-2024-1221 or the next vulnerability affects your stack