What’s Vulnerable › Vulnerabilities
CVE-2024-12226
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-16 · updated 2026-06-17
- Weakness: CWE-532
Description
In affected versions of the Octopus Kubernetes worker or agent, sensitive variables could be written to the Kubernetes script pod log in clear-text. This was identified in Version 2 however it was determined that this could also be achieved in Version 1 and the fix was applied to both versions accordingly.
Affected products
- Octopus Deploy Kubernetes Worker or Kubernetes Agent: from 1.x before 1.19.0; from 2.x before 2.8.0 — fixed in 1.19.0, 2.8.0
How to fix
Upgrade to a fixed version: Octopus Deploy Kubernetes Worker or Kubernetes Agent 1.19.0, 2.8.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-12226 or the next vulnerability affects your stack