What’s Vulnerable › Vulnerabilities

CVE-2024-12247: Improper propagation of permission scheme updates across cluster nodes

Description

Mattermost versions 9.7.x <= 9.7.5, 9.8.x <= 9.8.2 and 9.9.x <= 9.9.2 fail to properly propagate permission scheme updates across cluster nodes which allows a user to keep old permissions, even if the permission scheme has been updated.

Affected products

How to fix

Upgrade to a fixed version: Mattermost 9.7.6, 9.8.3, 9.9.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-12247 or the next vulnerability affects your stack