What’s Vulnerable › Vulnerabilities
CVE-2024-12268: Responsive Blocks – WordPress Gutenberg Blocks <= 1.9.7 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-24 · updated 2026-06-17
- Weakness: CWE-79
Description
The Responsive Blocks – WordPress Gutenberg Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'responsive-block-editor-addons/portfolio' block in all versions up to, and including, 1.9.7 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- CyberChimps Responsive Blocks: before 1.9.8 — fixed in 1.9.8
How to fix
Upgrade to a fixed version: CyberChimps Responsive Blocks 1.9.8. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3208350/responsive-block-editor-addons/tags/1.9.8/src/blocks/portfolio/index.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/0e951b97-3d17-4360-8fec-393e2f0c13d2?source=cve
Get alerted when CVE-2024-12268 or the next vulnerability affects your stack