What’s Vulnerable › Vulnerabilities
CVE-2024-12279: WP Social AutoConnect <= 4.6.2 - Cross-Site Request Forgery to Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-04 · updated 2026-06-17
- Weakness: CWE-352
Description
The WP Social AutoConnect plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 4.6.2. This is due to missing or incorrect nonce validation on a function. This makes it possible for unauthenticated attackers to inject malicious web scripts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- Justin Klein WP Social AutoConnect: before 4.6.3 — fixed in 4.6.3
How to fix
Upgrade to a fixed version: Justin Klein WP Social AutoConnect 4.6.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3211577/
- https://wordpress.org/plugins/wp-fb-autoconnect/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/392d8286-a5fd-4d5d-9f6a-f13564013edc?source=cve
Get alerted when CVE-2024-12279 or the next vulnerability affects your stack