What’s Vulnerable › Vulnerabilities
CVE-2024-12289: Boundary Controller Incorrectly Handles HTTP Requests On Initialization Which May Lead to a Denial of Service
- Severity: medium (CVSS 5.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-12-12 · updated 2026-06-17
- Weakness: CWE-460
Description
Boundary Community Edition and Boundary Enterprise (“Boundary”) incorrectly handle HTTP requests during the initialization of the Boundary controller, which may cause the Boundary server to terminate prematurely. Boundary is only vulnerable to this flaw during the initialization of the Boundary controller, which on average is measured in milliseconds during the Boundary startup process. This vulnerability, CVE-2024-12289, is fixed in Boundary Community Edition and Boundary Enterprise 0.16.4, 0.17.3, 0.18.2.
Affected products
- HashiCorp Boundary: from 0.8.0 before 0.16.4; from 0.17.0 before 0.17.3; from 0.18.0 before 0.18.2 — fixed in 0.16.4, 0.17.3, 0.18.2
How to fix
Upgrade to a fixed version: HashiCorp Boundary 0.16.4, 0.17.3, 0.18.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-12289 or the next vulnerability affects your stack