What’s Vulnerable › Vulnerabilities
CVE-2024-12302: Icegram Engage < 3.1.32 - Author+ Stored XSS
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-01-06 · updated 2026-06-17
- Weakness: CWE-79
Description
The Icegram Engage WordPress plugin before 3.1.32 does not sanitise and escape some of its Campaign settings, which could allow authors and above to perform Stored Cross-Site Scripting attacks
Affected products
- Icegram Engage: before 3.1.32 — fixed in 3.1.32
How to fix
Upgrade to a fixed version: Icegram Engage 3.1.32. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-12302 or the next vulnerability affects your stack