What’s Vulnerable › Vulnerabilities
CVE-2024-12311: Email Subscribers < 5.7.44 - Admin+ SQL Injection
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-01-06 · updated 2026-06-17
- Weakness: CWE-89
Description
The Email Subscribers by Icegram Express WordPress plugin before 5.7.44 does not sanitize and escape a parameter before using it in a SQL statement, allowing admins to perform SQL injection attacks
Affected products
- icegram Email Subscribers & Newsletters – Email Marketing, Post Notifications & Newsletter Plugin for WordPress: before 5.7.44 — fixed in 5.7.44
How to fix
Upgrade to a fixed version: icegram Email Subscribers & Newsletters – Email Marketing, Post Notifications & Newsletter Plugin for WordPress 5.7.44. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-12311 or the next vulnerability affects your stack