What’s Vulnerable › Vulnerabilities
CVE-2024-12316: Jupiter X Core <= 4.8.5 - Missing Authorization to Unauthenticated Popup Template Export
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-07 · updated 2026-06-17
- Weakness: CWE-862
Description
The Jupiter X Core plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the export_popup_action() function in all versions up to, and including, 4.8.5. This makes it possible for unauthenticated attackers to export popup templates.
Affected products
- artbees Jupiter X Core: before 4.8.6 — fixed in 4.8.6
How to fix
Upgrade to a fixed version: artbees Jupiter X Core 4.8.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/jupiterx-core/trunk/includes/popups/class.php#L475
- https://plugins.trac.wordpress.org/changeset/3214798/jupiterx-core/trunk/includes/popups/class.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/5db195c1-8917-4465-a5ca-21089afb0bc7?source=cve
Get alerted when CVE-2024-12316 or the next vulnerability affects your stack