What’s Vulnerable › Vulnerabilities
CVE-2024-12321: WC Affiliate <= 2.3.9 - Reflected XSS
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-01-27 · updated 2026-06-17
- Weakness: CWE-79
Description
The WC Affiliate WordPress plugin through 2.3.9 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin.
Affected products
- codexpert WC Affiliate – WooCommerce Affiliate Plugin: before 2.4 — fixed in 2.4
How to fix
Upgrade to a fixed version: codexpert WC Affiliate – WooCommerce Affiliate Plugin 2.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/d4c55d30-1c15-41ee-95e0-670891d67684/
- https://wpscan.com/vulnerability/d4c55d30-1c15-41ee-95e0-670891d67684/
Get alerted when CVE-2024-12321 or the next vulnerability affects your stack