What’s Vulnerable › Vulnerabilities
CVE-2024-12334: WC Affiliate – A Complete WooCommerce Affiliate Plugin <= 2.4 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-26 · updated 2026-06-17
- Weakness: CWE-79
Description
The WC Affiliate – A Complete WooCommerce Affiliate Plugin plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via any parameter in all versions up to, and including, 2.4 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Affected products
- codexpert WC Affiliate – WooCommerce Affiliate Plugin: before 2.5 — fixed in 2.5
How to fix
Upgrade to a fixed version: codexpert WC Affiliate – WooCommerce Affiliate Plugin 2.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3224312/wc-affiliate
- https://www.wordfence.com/threat-intel/vulnerabilities/id/efca1ee2-2038-440e-941c-22533b4d833b?source=cve
Get alerted when CVE-2024-12334 or the next vulnerability affects your stack