What’s Vulnerable › Vulnerabilities
CVE-2024-12336: WC Affiliate – A Complete WooCommerce Affiliate Plugin <= 2.5.3 - Missing Authorization to Authenticated (Subscriber+) Sensitive Information Exposure via wf-export-all
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-15 · updated 2026-06-17
- Weakness: CWE-862
Description
The WC Affiliate – A Complete WooCommerce Affiliate Plugin plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the 'export_all_data' function in all versions up to, and including, 2.5.3. This makes it possible for authenticated attackers, with Subscriber-level access and above, to expose sensitive affiliate data, including personally identifiable information (PII).
Affected products
- codexpert WC Affiliate – WooCommerce Affiliate Plugin: before 2.6 — fixed in 2.6
How to fix
Upgrade to a fixed version: codexpert WC Affiliate – WooCommerce Affiliate Plugin 2.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wc-affiliate/trunk/src/AJAX.php#L903
- https://plugins.trac.wordpress.org/changeset/3256435/wc-affiliate/trunk/src/AJAX.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/cf0fb349-4cb8-4cf3-ae7c-5c4dcc6fd4f7?source=cve
Get alerted when CVE-2024-12336 or the next vulnerability affects your stack