What’s Vulnerable › Vulnerabilities
CVE-2024-12370: WP Hotel Booking <= 2.1.5 - Missing Authorization
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-17 · updated 2026-06-17
- Weakness: CWE-284
Description
The WP Hotel Booking plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check when adding rooms in all versions up to, and including, 2.1.5. This makes it possible for unauthenticated attackers to add rooms with custom prices.
Affected products
- thimpress WP Hotel Booking: before 2.1.6 — fixed in 2.1.6
How to fix
Upgrade to a fixed version: thimpress WP Hotel Booking 2.1.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3210798%40wp-hotel-booking%2Ftags%2F2.1.5&new=3214765%40wp-hotel-booking%2Ftags%2F2.1.6
- https://www.wordfence.com/threat-intel/vulnerabilities/id/5df32365-5381-48e0-9313-7e83c4c6c440?source=cve
Get alerted when CVE-2024-12370 or the next vulnerability affects your stack