What’s Vulnerable › Vulnerabilities
CVE-2024-12380: Generation of Error Message Containing Sensitive Information in GitLab
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-13 · updated 2026-06-17
- Weakness: CWE-209
Description
An issue was discovered in GitLab EE/CE affecting all versions starting from 11.5 before 17.7.7, all versions starting from 17.8 before 17.8.5, all versions starting from 17.9 before 17.9.2. Certain user inputs in repository mirroring settings could potentially expose sensitive authentication information.
Affected products
- GitLab: from 11.5.0 before 17.7.7; from 17.8.0 before 17.8.5; from 17.9.0 before 17.9.2 — fixed in 17.7.7, 17.8.5, 17.9.2
How to fix
Upgrade to a fixed version: GitLab 17.7.7, 17.8.5, 17.9.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-12380 or the next vulnerability affects your stack